Xubuntu (III): ¡Funciona!

Tercer post de la serie sobre Xubuntu, sobre cómo logré hacer funcionar mi modem SpeedTouch ADSL vía USB y mi antiquísima tarjeta de sonido ALS007

Tal y como había previsto, tuve dos problemas grandotes, de esos que atentaban a la permanencia de Xubuntu, o que más bien me tentaban a sacarlo de inmediato: el módem y la tarjeta de sonido. Para alguien que la mayor parte del tiempo que está frente al PC está conectado a Internet y escuchando música, esto era un desastre. Claro, todo lo demás funcionaba perfecto, pero ante estas fallas costaba mucho enfocarse en “todo lo demás”.

Primer Round: el modem

SpeedTouchPor suerte la comunidad en torno a Ubuntu (también de Linux y todo el software Open Source en general) es bastante activa y militante, y sin esforzarme demasiado encontré un par de guías muy detalladas para poder hacer funcionar el modem SpeedTouch:

SpeedTouch HOWTO
Un artículo del wiki de la comunidad de usuarios de Ubuntu, muy detallado y actualizado, que explica perfectamente cómo lograr que funcione sin problemas. Está lleno de algunas cuestiones bastante técnicas, es cierto (como tener que crear scripts que deben cargarse al inicio) pero es posible seguirlas sin entender nada de lo que se está haciendo (aunque al rato se acaba por comprender bastante bien). De hecho, yo lo seguí sin entender “ni jota” y resultó perfecto
El driver Speedtouch del Kernel de Linux y Ubuntu
Es básicamente la misma guía que la anterior, pero en español… aun así es probable que no se entienda mucho lo que estás haciendo, pero de que resulta, resulta. Me parece que está un poco desactualizada o le faltan algunas secciones, por lo que probablemente sea mejor ir comparando con la anterior, pero de todos modos es una referencia muy buena

Segundo Round: la tarjeta de sonido

Me quedaba por resolver el funcionamiento de la tarjeta de sonido, para la cual prácticamente no tenía esperanzas ya que es muy vieja, a tal punto que se conecta vía ISA (un tipo de conexión que hoy, y desde hace varios años, ya no existe). Sin embargo el resultado anterior me había dejado con ánimo, por lo que me lancé a la búsqueda de algún artículo que me pudiera servir: encontré de todo, desde que básicamente debía crear no-se-qué script y compilar no-se-qué driver (o módulo, no importa porque de todos modos estaba muy lejos de mis posibilidades) hasta llegar nuevamente al lugar del que no debía haber salido: el wiki de documentación comunitaria de Ubuntu

Ubuntu Community Documentation

Finalmente, la mejor alternativa era a la vez la más fácil: en How To Setup Sound Cards encontré un método para lograr que mi tarjeta de sonido funcionara, tan sencillo como abrir una ventana del terminal y ejecutar la orden sudo modprobe snd-als100; en mi caso funcionó inmediatamente esta opción pero si no fuera así puedes ejecutar una vez más el comando sudo modprobe con otra de los módulos para tu tarjeta de sonido (la lista completa está en el artículo del wiki)

Para cargar automáticamente el módulo al inicio la cosa me fue un poco más complicada, pero finalmente la respuesta estaba en el mismo artículo: sólo era necesario abrir una terminal, dirigirme al directorio /etc y editar el archivo modules: sudo nano modules y agregar a esa lista el nombre del módulo de tu tarjeta de sonido, la mía quedó así:

# /etc/modules: kernel modules to load at boot time.
#
# This file contains the names of kernel modules that should be loaded
# at boot time, one per line. Lines beginning with "#" are ignored.

lp
psmouse
snd-als100

Y eso es todo, modem y tarjeta de sonido funcionando

2 thoughts on “Xubuntu (III): ¡Funciona!

Comments are closed.